Liquidity Provider Issue
Incident Report for Currencycloud
Resolved
Third party liquidity providers are operational again, please contact us if there any further issues booking trades.
Posted Apr 13, 2017 - 08:57 UTC
Investigating
Trading on our secondary liquidity provider is currently experiencing issues. We are currently investigating and will provide an update as soon as possible.
Posted Apr 13, 2017 - 08:00 UTC
Monitoring
Our liquidity provider is currently having availability issues. We are currently offering a limited Spot tenor only trading service.
Posted Apr 13, 2017 - 07:26 UTC