Unable to retrieve rates or create conversions
Incident Report for Currencycloud
Resolved
This incident has been resolved.
Posted Mar 26, 2024 - 23:16 UTC
Investigating
We are experiencing a problem retrieving rates and creating new conversions, this is due to a 3rd party outage and we are working with the supplier on fixing the problem.
Posted Mar 26, 2024 - 22:37 UTC
This incident affected: Conversions.