Customer Support Phone Lines Not Working
Incident Report for Currencycloud
Resolved
Phone lines are now back up and running.
Posted Apr 20, 2017 - 10:25 UTC
Identified
We are experiencing problems with our phones, this is due to a 3rd party outage, and the supplier is working on fixing the problem.
Posted Apr 20, 2017 - 09:50 UTC