USD LOCAL Payment Processing Delays
Incident Report for Currencycloud
Resolved
This incident has been resolved.
Posted Jun 29, 2020 - 14:50 UTC
Monitoring
A fix has been put in place and USD local payments are being sent as normal.

No USD Local payments have missed cut off, the issue affected the payment being moved to Completed
Posted Jun 29, 2020 - 13:27 UTC
Update
We are continuing to work on the issue, no payment cut offs have been missed
Posted Jun 29, 2020 - 12:30 UTC
Investigating
We are currently investigating an issue that is causing a delay in processing LOCAL USD payments.

We are working to resolve this as quickly as possible.
Posted Jun 29, 2020 - 08:58 UTC
This incident affected: Payments.