Conversion and Payment Delays
Incident Report for Currencycloud
Resolved
The back log of conversions and payments has now been cleared and processing across the platform is back to normal
Posted Apr 18, 2019 - 15:35 UTC
Monitoring
Conversions are back up and running, payments are being processed. We continue to monitor as we clear the back log
Posted Apr 18, 2019 - 13:03 UTC
Identified
We have now identified the root cause and we are working on a fix
Posted Apr 18, 2019 - 09:22 UTC
Investigating
We are currently experiencing issues with conversions settling on the Cash Manager platform. This will also impact payments from being released. We are urgently investigating this issue
Posted Apr 18, 2019 - 08:10 UTC
This incident affected: Payments and Conversions.