Delay updating EUR balances
Incident Report for Currencycloud
Resolved
We have now received the required data from our banking partner and we are now processing collections.
We are awaiting confirmation regarding the cause of the delay from our banking partner.
Apologies for any inconvenience caused by any delayed EUR balance updates.
Posted Dec 06, 2019 - 10:54 UTC
Investigating
EUR Collections are currently not being processed due to a banking partner issue.
This has affected all EUR Collections due to be processed this morning and will result in balances not being updated until tomorrow for clients who fund this way.
We are in contact with our banking partner and will provide further updates as soon as we receive them.
Posted Dec 06, 2019 - 09:32 UTC
This incident affected: Balances.