USD LOCAL Payment Processing Delays
Incident Report for Currencycloud
Resolved
We have resolved the problems with LOCAL USD payments are now being processed
Posted Jan 16, 2020 - 17:12 UTC
Update
We have identified the problem and are working to resolve the issue
Posted Jan 16, 2020 - 16:32 UTC
Investigating
We are currently investigating an issue that is causing a delay in processing LOCAL USD payments
Posted Jan 16, 2020 - 15:12 UTC
This incident affected: Payments.