Delay updating EUR balances
Incident Report for Currencycloud
Resolved
The fix has been confirmed as successful and service restored to normal. Apologies for any inconvenience caused by the delay.
Posted Oct 04, 2019 - 12:32 UTC
Monitoring
A fix has been implemented, however funds sent between 16:30 on 3rd October and 10:00 on 4th October will see corresponding balance updates delayed until Monday morning.

We will continue to monitor the service before resolving the issue.
Posted Oct 04, 2019 - 12:02 UTC
Identified
We are currently experiencing delays in updating customer EUR balances due to a collections issue with a banking partner who we are working with to resolve as soon as possible.
Posted Oct 04, 2019 - 08:52 UTC
This incident affected: Balances.