Issues Using Branded Direct Platform
Incident Report for Currencycloud
Resolved
The incident has been resolved
Posted May 23, 2019 - 14:41 UTC
Monitoring
A fix has been implemented and we are monitoring
Posted May 23, 2019 - 14:27 UTC
Identified
The issue has been identified and fix is being implemented
Posted May 23, 2019 - 14:24 UTC
Investigating
We are currently experiencing some issues trying to log in to our Direct platform if using paydirect.io. If you are connecting via the API or http://direct.currencycloud.com this will not affect you.

We are currently investigating
Posted May 23, 2019 - 14:07 UTC
This incident affected: Paydirect.io / Direct.