Local EUR, GBP, DKK, SEK and NOK payment delays
Incident Report for Currencycloud
Resolved
This issue has now been resolved, the backlog of delayed payments has cleared and no further delays are being observed.

Apologies for any inconvenience this may have caused.
Posted Sep 14, 2020 - 09:50 UTC
Investigating
We have observed delays processing local EUR, GBP, DKK, SEK and NOK payments this morning.
DKK payments created this morning will be delayed by one day.

We are working with our banking partner to resolve this issue.
Posted Sep 14, 2020 - 08:31 UTC
This incident affected: Payments.