Potential USD Processing Delays

Incident Report for Currencycloud

Postmortem

Overview
An incident regarding potential USD payment processing delays was investigated and resolved. Communications were issued and Banking Partner systems were monitored throughout.  

Client Impact
Payment processing was confirmed to have operated normally, and no client impact was observed. Potential delays were communicated proactively while systems were monitored. 

Root Cause
External vendor systems used by our Banking Partner experienced service disruptions due to wide cloud service outages, that could lead to slower wire processing. 

Remediation
The Banking Partner restored normal processing by resolving the underlying vendor system issues. Ongoing monitoring was conducted to ensure service stability and prevent recurrence. 

Currencycloud Confidential
Posted Nov 04, 2025 - 11:34 UTC

Resolved

The issue impacting our local USD network partners has been resolved.

We have confirmed that payment processing operated normally throughout the incident, and no client impact was identified.
Posted Oct 31, 2025 - 15:01 UTC

Update

Our local USD network partners are currently being monitored following reports of service disruptions. At this time, payment processing is operating normally, and no impact to transactions has been observed.

Our teams continue to review the situation with our partners to ensure service stability and preempt any potential delays.

We will provide further updates as more information becomes available.

Thank you for your patience and understanding.
Posted Oct 30, 2025 - 17:25 UTC

Monitoring

Our local USD network partners are currently experiencing delays in wire transaction processing due to a service disruptions.

Incoming and outgoing USD payments may be delayed.

Our teams are actively working with our partners to resolve the issue as quickly as possible.

We will provide further updates as more information becomes available.

Thank you for your patience and understanding.
Posted Oct 29, 2025 - 17:20 UTC
This incident affected: Payments.