Delay to SGD Processing

Incident Report for Currencycloud

Postmortem

Incident Summary

On 28 March, a minor issue resulted in a processing delay for a sub-set of SGD payments scheduled for value date 28 March. These transactions were completed with a one-day delay.

Resolution

All payments affected were successfully processed on 29 March. It has been confirmed that the issue is fully resolved and payment processing is operating normally.

Where you have questions about specific transactions or require further assistance, do not hesitate to contact your support representative.

Posted May 30, 2025 - 16:00 UTC

Resolved

Incident Resolved

We recently experienced an internal issue causing delays in SGD payments processing.

The issue has been successfully resolved. However, a subset of transactions dated 28th May will experience a one-day delay in settlement.

We apologise for any inconvenience this may have caused and appreciate your understanding.

If you have any questions or need further assistance, please contact our support team.
Posted May 29, 2025 - 08:47 UTC

Identified

We are currently experiencing delays in processing SGD payments due to an internal issue. Our teams are actively working to resolve this as quickly as possible.

Thank you for your patience, and we apologise for any inconvenience caused.
Posted May 28, 2025 - 11:41 UTC
This incident affected: Payments.