Unable to quote or book APAC currencies
Incident Report for Currencycloud
Resolved
Service has been restored, we will continue to monitor.
Posted Jun 23, 2021 - 18:54 UTC
Update
We are still working with our FX provider to resolve the issue.
Posted Jun 23, 2021 - 18:41 UTC
Investigating
We are currently investigating an issue impacting booking trades for APAC currencies. We have reached out to our FX provider to help resolve.
Posted Jun 23, 2021 - 17:26 UTC
This incident affected: Conversions.