Retrieving rates and creating Conversions
Incident Report for Currencycloud
Postmortem

Overview
An incident occurred which allowed the platform to remain available, however limited the ability to retrieve rates and create conversions. This was due to an issue with our banking partner which in turn broke our connection to them.

Timeline
12:38 UTC - Currencycloud alerting identified external connection failures to our banking partner, who were subsequently engaged
12:41 UTC - Platform health checks confirm no internal issues
13:31 UTC - Banking partner confirmed they were experiencing issues at their datacenter and were working to resolve, during this period service was seen to recover intermittently
13:38 UTC - Service fully restored
13:54 UTC - Customers informed after a period of monitoring following previous intermittent failure observations
14:33 UTC - Incident confirmed as resolved after a further period of monitoring

Resolution
Once our banking partner resolved their issue the service was restored

Root Cause Analysis
To be confirmed by partner

Remediation Items
• Resilience will be improved as we build with additional banking partners

Posted Sep 10, 2020 - 16:01 UTC

Resolved
This incident has been resolved.
Posted Sep 10, 2020 - 14:33 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 10, 2020 - 13:54 UTC
Investigating
We are experiencing a problem retrieving rates and creating new conversions, this is due to a 3rd party outage and we are working with the supplier on fixing the problem.
Posted Sep 10, 2020 - 13:01 UTC
This incident affected: Conversions.