DIRECT customers getting errors creating payments
Incident Report for Currencycloud
Resolved
This incident has been resolved.
Posted Jun 24, 2022 - 10:17 UTC
Investigating
Customers using the DIRECT platform to create payments maybe see an internal server error message. Teams are working to resolve.
Posted Jun 24, 2022 - 08:49 UTC
This incident affected: Payments and Paydirect.io / Direct.