Platform Outage

Incident Report for Currencycloud

Postmortem

Resolution

Our engineering team acted quickly to investigate and isolate the issue. Key actions included identifying the root cause as an encryption-related data issue in the CRM service, temporarily setting the problematic field to null, and mitigating the impact.

This allowed services to return to normal.

Posted Jun 06, 2025 - 08:35 UTC

Resolved

Incident has been resolved.
Posted May 29, 2025 - 11:49 UTC

Investigating

We are investigating an issue that is impacting our platform

We are seeing a high number of errors on Conversion Create calls

Further updates will follow as teams investigate the cause
Posted May 29, 2025 - 10:41 UTC
This incident affected: API, Payments, and Conversions.