Payment Processing Delays
Incident Report for Currencycloud
Resolved
The payments backlog has now cleared, this incident has been resolved.
Posted Jul 04, 2019 - 12:29 UTC
Monitoring
This issue has been fixed and the backlog of delayed payments is being processed. We will monitor until that is completed.
Posted Jul 04, 2019 - 12:25 UTC
Investigating
We are currently experiencing some issues processing payments and are urgently investigating. Local GBP, EUR, NOK, DKK, SEK payments may be delayed.
Posted Jul 04, 2019 - 09:51 UTC
This incident affected: Payments.