Currencycloud Internet Service Provider Outage
Incident Report for Currencycloud
Resolved
This issue has now been resolved, and all systems are operating normally. If you need any further assistance, please contact us.
Posted May 21, 2018 - 08:38 UTC
Monitoring
Our internet service provider have resolved their outage. We are now able to process all payments and funds, with all communication channels back to normal. If you are experiencing any further issues, please contact us.
Posted May 21, 2018 - 08:29 UTC
Identified
We are currently experiencing issues with our internet provider. All services to customers should be unaffected, however, the processing of payments and funds will be experiencing a delay. This is affecting communications between us and yourselves with phone and email. We are looking to resolve this as soon possible.
Posted May 21, 2018 - 08:16 UTC
This incident affected: Payments and Balances.