Beneficiary creation issues
Incident Report for Currencycloud
Resolved
This incident has been resolved.
Posted May 05, 2021 - 19:44 UTC
Monitoring
Our 3rd party Validator has identified and resolved the issue.

No further errors have been seen and we will continue to monitor the situation
Posted May 05, 2021 - 18:51 UTC
Investigating
We are seeing an increased number of failures on beneficiary creation and are currently investigating with our validation partner.
Apologies for any inconvenience this may be causing.
Posted May 05, 2021 - 18:32 UTC
This incident affected: API and Payments.