Unable to sell USD buy APAC currencies
Incident Report for Currencycloud
Resolved
The issue is resolved, but we are continuing to investigate the root cause of the issue.
Posted Oct 21, 2021 - 15:06 UTC
Investigating
We are investigating an issue that, earlier today, had been impacting customers booking APAC trades when selling USD with a value date of today.

Customers would have received a message

"This transaction has failed due to an unknown internal system error"
Posted Oct 21, 2021 - 15:02 UTC
This incident affected: API and Conversions.