Payment processing delays
Incident Report for Currencycloud
Resolved
The incident has been resolved.
Posted Nov 11, 2019 - 12:53 UTC
Monitoring
The backlog has been cleared and the system is now operational. We shall continue to monitor the service prior to resolving the incident.
Posted Nov 11, 2019 - 11:49 UTC
Identified
We have identified the issue and implemented a fix. Payments are being processed but some payments and their corresponding confirmation notifications may still be delayed slightly as the backlog is worked through.
Posted Nov 11, 2019 - 11:06 UTC
Investigating
We are currently experiencing some issues with our payments processing infrastructure, resulting in delays to all payment channels. We are urgently investigating the root cause.
Posted Nov 11, 2019 - 10:21 UTC
This incident affected: Payments.