Delay updating EUR and USD balances
Incident Report for Currencycloud
Resolved
This incident has been resolved.
Posted May 29, 2020 - 12:42 UTC
Monitoring
The Collections backlog has now cleared and we are monitoring the service.

Apologies for any inconvenience this may have caused.
Posted May 29, 2020 - 11:37 UTC
Investigating
We are currently investigating an issue with EUR and USD Collections

This has impacted Collections due to be processed this morning and will result in a delay in balances being updated for clients who fund this way.

We are urgently investigating and will provide further updates as soon as we have them.
Posted May 29, 2020 - 08:59 UTC
This incident affected: Balances.