Conversions - 3rd Party Partial Outage

Incident Report for Currencycloud

Postmortem

Summary

Due to a technical issue with one of our 3rd party providers on the evening of Monday 9th June we experiencing a short intermittent issue with creating new conversions.

The issue was identified via our active monitoring and escalated to our third-party partner to whom took immediate action to remediate.

A small percentage of a subset of new conversions were impacted, while the majority remained unaffected. The underlying external technical issue was resolved and the service was fully restored with a couple of hours.

Posted Jun 10, 2025 - 10:39 UTC

Resolved

This incident has been resolved.
Posted Jun 09, 2025 - 00:10 UTC

Investigating

We are experiencing some problems creating new conversions on one of our 3rd party providers. The issue has been identified and is being worked on. It is currently affecting a small percentage of our flow and the majority of conversion requests are working.
Posted Jun 08, 2025 - 22:06 UTC
This incident affected: Conversions.