Issue retrieving beneficiaries and static data
Incident Report for Currencycloud
Resolved
This incident has been resolved.
Posted Nov 07, 2019 - 18:43 UTC
Update
All services restored following a release roll back.
Posted Nov 07, 2019 - 18:41 UTC
Update
We are continuing to investigate this issue.
Posted Nov 07, 2019 - 18:40 UTC
Investigating
We have a major incident impacting beneficiaries and static data via our API following a scheduled release. We are currently rolling back this release to restore these services.
Posted Nov 07, 2019 - 18:14 UTC
This incident affected: API.