Issues contacting Customer Support via phone
Incident Report for Currencycloud
Resolved
This incident has been resolved.
Posted Nov 12, 2020 - 18:10 UTC
Monitoring
This intermittent issue unfortunately resulted in some customer telephone calls not being able to be taken today, but it has now been resolved.

We will continue to closely monitor incoming calls for further issues.

Apologies if this has caused any inconvenience.
Posted Nov 12, 2020 - 17:01 UTC
Investigating
We are currently experiencing some issues with our phone system, if you are unable to get through to Customer Support by phone please email support@currencycloud.com.
Posted Nov 12, 2020 - 11:48 UTC
This incident affected: Other.