Delay in local Nordic currencies NOK, SEK, DKK
Incident Report for Currencycloud
Resolved
We have managed to work around the issue and submit the payments to our provider.

Due to the work around we have managed to not miss same day cut off for these payments
Posted Apr 30, 2021 - 10:22 UTC
Investigating
We have experienced an issue submitting local nordic currencies, that will cause a delay.

The following currencies have missed same day cut off

NOK, SEK, DKK
Posted Apr 30, 2021 - 09:53 UTC
This incident affected: Payments.