Local USD payments stuck ready to send
Incident Report for Currencycloud
Resolved
We have resolved the issue and all payments have been processed
Posted Nov 29, 2022 - 15:58 UTC
Investigating
We are investigating an issue that is causing LOCAL USD payments to be stuck in ready to send and to progress
Posted Nov 29, 2022 - 14:14 UTC
This incident affected: Payments.