Payment and Conversion issues
Incident Report for Currencycloud
Resolved
The issue has been resolved and all services are now operational.
Posted Aug 21, 2019 - 14:02 UTC
Monitoring
A fix has been implemented and we are currently monitoring the service.
Posted Aug 21, 2019 - 13:48 UTC
Investigating
We are currently experiencing issues creating payments and conversions. This is being investigated with the highest priority.
Posted Aug 21, 2019 - 12:53 UTC
This incident affected: Payments and Conversions.