Payment Processing Delays
Incident Report for Currencycloud
Resolved
This incident has been resolved.
Posted Nov 13, 2019 - 19:09 UTC
Identified
Some EUR, NOK, SEK, DKK and GBP Payments made via SEB bank may be delayed
Posted Nov 13, 2019 - 16:57 UTC
This incident affected: Payments.