Payment Creation Issues
Incident Report for Currencycloud
Resolved
A fix has now been released for this issue.
Posted May 24, 2017 - 18:46 UTC
Identified
We have found the cause of the issue and currently in the process of fixing this. Further updates will be given shortly.
Posted May 24, 2017 - 12:45 UTC
Investigating
We are currently experiencing some issues with creating payments through Direct. This issue is currently being investigating.
Posted May 23, 2017 - 15:33 UTC