Unable to get rates GBP/EUR and EUR/GBP
Incident Report for Currencycloud
Resolved
This incident has been resolved.
Posted Nov 25, 2022 - 10:40 UTC
Monitoring
We have implemented a fixed to resolve the issue with TOD rates and issue has been resolved. We are continuing to monitor the situation
Posted Nov 25, 2022 - 09:54 UTC
Investigating
Issue is impacting TOD rates, TOM and SPOT is currently available for clients. FX Provider is still working to resolve the issue.
Posted Nov 25, 2022 - 08:59 UTC
This incident affected: Conversions.