Platform Performance Degraded
Incident Report for Currencycloud
Resolved
This Incident has now been resolved. The backlog of delayed payments has been processed and the platform performance restored. Apologies once again for any inconvenience caused.
Posted May 26, 2020 - 11:11 UTC
Monitoring
The performance issues have been resolved and we are currently monitoring the service.
Posted May 26, 2020 - 10:26 UTC
Update
Due to the current performance issues, we are experiencing Payment Delays for LOCAL EUR, GBP, SEK, DKK and NOK

As a result we have missed cut offs for SEK, DKK and NOK

We continue to investigate with the highest priority.
Posted May 26, 2020 - 10:06 UTC
Investigating
We are currently experiencing significant performance degradation across the platform and are urgently investigating.
Apologies for any inconvenience this is causing.
Posted May 26, 2020 - 08:29 UTC
This incident affected: API, Payments, and Paydirect.io / Direct.