We are currently investigating an issue with LOCAL EUR Collections
Incident Report for Currencycloud
Resolved
This incident has been resolved.
Posted Sep 11, 2020 - 17:16 UTC
Investigating
Collections due to be received this afternoon from Local EUR Collections provider will result in a delay in balances being updated for clients who fund this way.

We are in contact with our banking partner and will provide further updates as soon as we receive them.
Posted Sep 11, 2020 - 16:24 UTC
This incident affected: Balances.