Local HUF, HRK, CZK, RON payments delayed

Incident Report for Currencycloud

Resolved

This incident has been resolved.
Posted Apr 27, 2023 - 18:51 UTC

Monitoring

We experienced an issue processing HUF, HRK, CZK, RON local payments, any payment dated for the 27th may be delayed by a day.
Posted Apr 27, 2023 - 12:29 UTC
This incident affected: Payments.