direct.currencycloud.com DEMO and PROD unavailable

Incident Report for Currencycloud

Resolved

This incident has been resolved.
Posted Jun 05, 2023 - 21:41 UTC

Update

Issue has been resolved
Posted Jun 05, 2023 - 15:48 UTC

Investigating

direct.currencycloud.com DEMO and PROD unavailable, we are investigating an outage to DEMO and PROD Direct URL
Posted Jun 05, 2023 - 15:31 UTC
This incident affected: Paydirect.io / Direct.