Customer Support Tickets
Incident Report for Currencycloud
Resolved
This Incident has now been resolved. Apologies for any delay in responding to your tickets, our support team will be working through the backlog as quickly as possible.
Posted Sep 09, 2020 - 13:14 UTC
Identified
We are currently experiencing an issue with our internal Customer Support system, which may cause a delay in responding to tickets you have raised. This will also impact the use of the Support functionality on the platform, via the Direct UI.

If you have urgent issues that need immediate support please contact our support team by phone, +44 (0) 203 597 4800
Posted Sep 09, 2020 - 12:02 UTC
This incident affected: Other.