Unable to process CAD local payments
Incident Report for Currencycloud
Resolved
This incident has been resolved.
Posted Feb 21, 2020 - 11:11 UTC
Monitoring
We have implemented a fix with our banking partner to allow these payments to proceed, will will be monitoring the situation carefully.
Posted Feb 20, 2020 - 10:02 UTC
Update
We are continuing to work on a fix for this issue.
Posted Feb 18, 2020 - 08:49 UTC
Identified
Due to an issue with our banking partner we are currently unable to process CAD local payments. The issue is under investigation and an update will be provided when additional information is available.
Posted Feb 15, 2020 - 12:13 UTC
This incident affected: Payments.