Demo Environment - Planned Outage
Incident Report for Currencycloud
Resolved
The maintenance work has now been completed.
Posted Nov 12, 2023 - 13:37 UTC
Investigating
Demo environment platform scheduled maintenance work is currently still in progress.

We will provide an update shortly.
Posted Nov 12, 2023 - 12:36 UTC
This incident affected: API, Payments, Conversions, Paydirect.io / Direct, Notifications, Balances, and Other.