Third Party Quote Disruption
Incident Report for Currencycloud
Resolved
This incident has been resolved.
Posted Apr 17, 2019 - 17:58 UTC
Monitoring
Trading for NOK, SEK, DKK and PLN has now returned. We will continue to monitor this.
Posted Apr 17, 2019 - 15:34 UTC
Investigating
Our provider is currently experiencing issues with trading for NOK, SEK, DKK and PLN. They are currently investigating and we expect this to be resolved shortly.
Posted Apr 17, 2019 - 15:11 UTC
This incident affected: Conversions.