www.currencycloud.com unavailable
Incident Report for Currencycloud
Resolved
Site availability was restored at 18:28 UTC. An issue with our 3rd party service provider as been resolved.
Posted Jan 13, 2023 - 19:07 UTC
Investigating
We are investigating an issue with the currencycloud.com website.

Teams are working to restore full functionality as soon as possible
Posted Jan 13, 2023 - 18:14 UTC
This incident affected: Other.