Confirmation of Payee - Update
Incident Report for Currencycloud
Resolved
This incident has been resolved.
Posted Dec 13, 2023 - 11:53 UTC
Identified
We have seen that not all accounts have been resolved

A small set of accounts created between the hours of 00:00 to 09:30 are still experiencing issues.

We expect this to be resolved by 09:30 tomorrow
Posted Dec 12, 2023 - 12:04 UTC
This incident affected: Balances.