Important Update on DKK International Payments

Incident Report for Currencycloud

Postmortem

Overview

On 22 April 2025, a change in the handling of international payments in DKK by Danish banks necessitated system development on our Network Partner side. As an interim measure, our Network Partner reverted to a manual process, which resulted in DKK payments processing delays for a number of our clients.

Root Cause

The recent infrastructure changes across all Danish banks and central systems required adjustments in how several Danish financial institutions, including our Network Partner receive and handle international payments in DKK.

Remediation

The issue with the Danish Central Bank’s handling of funds has been corrected as part of an overnight fix however, our Network Partner will continue to manually apply funding until a permanent system update is implemented.

Posted 12 days ago. May 01, 2025 - 08:23 UTC

Resolved

Adjustments in how our network partner banks receives international payments in DKK have been upgraded, while further automotive developments are ongoing, due to enhanced controls potential impacts have ceased since Wednesday 23rd April.
Posted 17 days ago. Apr 25, 2025 - 16:22 UTC

Monitoring

Due to recent infrastructure changes across all Danish banks and central systems, there have been some adjustments in how our network partner banks receives international payments in DKK.

We're closely monitoring the situation to minimize any potential impact. As a precaution during this two-week adjustment period, a small number of DKK payments may experience minor delays in processing.

We appreciate your understanding and will continue to keep you informed. If you have any concerns or notice a delay, please don't hesitate to reach out — we're here to help
Posted 20 days ago. Apr 22, 2025 - 17:01 UTC
This incident affected: Payments.