Delay processing incoming funds
Incident Report for Currencycloud
Postmortem

Overview

On Thursday 9th January a change to the date format within the ‘accounts API’ service resulted in a backlog of instructions on route to transaction screening.

We invoked a status page in effort to promptly notify clients of potential delays in payment processing.

The backlog was mitigated through retriggering the transaction processing task and the change in format was reverted, promptly which addressing new requests.

Client Impact

All instructions processed successfully as per their value date.

Currencycloud Confidential
This memo furnished to you solely in your capacity as a client of Currencycloud and/or a participant in the Visa payments system. By accepting this memo you acknowledge that the information contained herein (the “Information”) is confidential and subject to the restrictions contained in confidentiality agreements, which limit your use of the Information. You agree to keep the Information confidential and not to use the Information for any purpose other than in your capacity as a customer of Currencycloud or as a participant in the Visa payments system. The Information may only be disseminated within your organization on a need-to-know. Please be advised that the Information may constitute material non-public information under U.S. federal securities laws and that purchasing or selling securities of Visa Inc. while being aware of material non-public information would constitute a violation of applicable U.S. federal securities laws
Posted Jan 15, 2025 - 08:57 UTC

Resolved
This incident has been resolved.
Posted Jan 09, 2025 - 14:47 UTC
Monitoring
Issue has been mitigated and pending transactions are being processed

We are monitoring the situation until cleared
Posted Jan 09, 2025 - 14:22 UTC
Investigating
We are investigating an issue impacting processing incoming funds
Posted Jan 09, 2025 - 13:48 UTC
This incident affected: Balances.