Issue with client onboarding forms
Incident Report for Currencycloud
Resolved
Issue identified and client impact resolved. A refresh might be required to allow the page to function correctly
Posted Oct 24, 2023 - 15:39 UTC
Investigating
We are investigating and issue with our onboarding forms not loading the drop down menu correctly.
Posted Oct 24, 2023 - 15:33 UTC
This incident affected: Paydirect.io / Direct.