Balance Transfer webhook notifications - Delayed
Incident Report for Currencycloud
Postmortem

Overview

On Thursday 9th January following the introduction of a recent configuration change our internal monitoring controls alerted due to a spike in web-hook error responses.

Investigation identified that a number of ‘Transfer Completed’ notifications were not being issued due to a ‘null’ response. A fix was implemented which immediately addressed any new instructions.

Impact analysis commenced to identify and retrigger all non-processed notifications. Which was completed successfully on Friday 10th January.

Client Impact

All instructions received on 9th January were processed successfully as per value date, a number of transfer complete notifications were delayed by 1 day

Currencycloud Confidential
This memo furnished to you solely in your capacity as a client of Currencycloud and/or a participant in the Visa payments system. By accepting this memo you acknowledge that the information contained herein (the “Information”) is confidential and subject to the restrictions contained in confidentiality agreements, which limit your use of the Information. You agree to keep the Information confidential and not to use the Information for any purpose other than in your capacity as a customer of Currencycloud or as a participant in the Visa payments system. The Information may only be disseminated within your organization on a need-to-know. Please be advised that the Information may constitute material non-public information under U.S. federal securities laws and that purchasing or selling securities of Visa Inc. while being aware of material non-public information would constitute a violation of applicable U.S. federal securities laws.
Posted Jan 15, 2025 - 08:59 UTC

Resolved
This incident has been resolved.
Posted Jan 10, 2025 - 16:12 UTC
Monitoring
A Fix has been deployed to resolve the issue, the team is currently working on resending any webhooks that have been impacted by this issue.
Posted Jan 09, 2025 - 17:43 UTC
Investigating
We are investigating an issue that is impacting some Balance Transfer webhook notifications

Team are working to resolve the issue and resend the delayed webhooks
Posted Jan 09, 2025 - 16:09 UTC
This incident affected: Notifications.