Unable to download Transaction reports
Incident Report for Currencycloud
Resolved
The issue has been resolved
Posted Oct 12, 2023 - 10:16 UTC
Investigating
We are investigating an issue that is preventing clients being able to download transactions reports.
Posted Oct 12, 2023 - 09:15 UTC
This incident affected: Paydirect.io / Direct.