GBP Local Payments Failing
Incident Report for Currencycloud
Resolved
The issue has been resolved by our banking partner, we have enabled the release schedule to restore service.

Payments that failed will need to be resubmitted
Posted Dec 05, 2024 - 17:03 UTC
Investigating
We are investigating an issue that is causing local GBP Payments to fail.

We are going to stop the release of these payments and reach out to our banking partner.

Pausing the release schedule will stop anymore payments from failing but delay their submission until the issue is resolved.
Posted Dec 05, 2024 - 16:13 UTC
This incident affected: Payments.