Local Euro Payment Failures

Incident Report for Currencycloud

Postmortem

Overview

A recent update resulted in a technical issue affecting a small number of local EUR payments, which failed with the error message "Technical error." Our teams promptly identified the root cause and applied a fix.

The system is now operating normally, and payments are processing as expected.

Client Impact

A limited number of payments were not successfully processed during the affected period. If you have received a failed status for any impacted payments, we kindly ask that you re-instruct those payments at your earliest convenience.

We apologise for any inconvenience caused and appreciate your continued understanding.

Posted Sep 11, 2025 - 16:29 UTC

Resolved

The technical issue affecting a small number of payments has now been fully resolved. All impacted payments have been identified, and no further issues are expected.

Where a payment has been failed under 'Technical' error please proceed to reinstruct.

We apologise for any inconvenience this may have caused and thank you for your patience during our investigation.
Posted Sep 05, 2025 - 10:46 UTC

Identified

We have identified an issue affecting a small number of local Euro payments that have failed due to a technical error. Our teams are actively investigating the root cause and working on remediation.

Further updates will be provided as they become available.

We apologise for any inconvenience and appreciate your patience.
Posted Sep 05, 2025 - 10:15 UTC
This incident affected: Payments.