Local SEK and DKK failures

Incident Report for Currencycloud

Resolved

The issue resolved and process returned to expected behaviour.

The failed payments require resubmission.
Posted Apr 01, 2025 - 12:49 UTC

Investigating

We are currently experiencing intermittent issues with our DKK and SEK Banking Partner, resulting in a higher than usual failure rate.

Investigation is underway, further update to be provided as soon as possible.
Posted Apr 01, 2025 - 11:44 UTC
This incident affected: Payments.