PLN and EUR Processing Delays

Incident Report for Currencycloud

Postmortem

Incident Summary

On 15th April 2025, Currencycloud experienced a temporary disruption in the processing of a subset of PLN and EUR payments. This was due to a localized and intermittent technical issue with one of our network partners.

Impact

As a result of this issue, a number of PLN and EUR payments were subject to a one-day processing delay. All affected payments have a value date of 8th April and were originally scheduled to be processed on 7th.

Resolution

The root cause of the disruption was promptly identified by our network partner and fully remediated on the same day. Following the resolution, normal payment processing resumed without further incident.

We understand the critical nature of timely payments for your business and your customers. We take incidents like this seriously and have worked closely with our partner to ensure additional safeguards are in place to prevent recurrence. We continuously monitor our systems and third-party providers to uphold the reliability and performance you expect from Currencycloud.

· A full review of monitoring and alerting related to payment processing has been completed
· Collaboration protocols with the affected network partner have been reviewed to improve incident response timeframes
· Ongoing monitoring indicates no additional impacts have been detected

We apologise for any inconvenience this may have caused and thank you for your patience and continued trust in Currencycloud.

If you have any further questions or concerns, please don’t hesitate to reach out to your account manager or our support team.

The Currencycloud Team

Posted Apr 17, 2025 - 14:20 UTC

Resolved

The issue with our network partner has been resolved, while some delays in processing were experienced for a subset of PLN payments value dated 15th April. Normal service has been restored, we continue to work with our network partner to mitigate any future such occurrences.
Posted Apr 16, 2025 - 08:00 UTC

Identified

We have identified an issue with our Network Partner which may result in the delayed processing of some PLN and EUR payments. We are actively working to resolve and shall continue to monitor the situation, further update to follow.
Posted Apr 15, 2025 - 11:49 UTC
This incident affected: Payments.